Back to overview
Resolved

Settlement delay for payments of 07-08/09 via Bancontact, Visa & Mastercard

Sep 10, 2026 at 12:26pm UTC
Affected services
Digiteal API - PROD

Resolved
Sep 11, 2026 at 8:05pm UTC

The last file for the settlement of the payments of 07/09 has been received and is being processed. The settlement will be completed on the next business day (Monday 14/09). We have requested a root cause analysis from the acquirer to avoid this incident repeating.

Updated
Sep 11, 2026 at 6:42am UTC

The BC/Visa/MC transactions of 08/09 have been settled on 10/09. We are still pending one file to be able to process the transactions of 07/09. We expect to have this resolved in the course of this morning.

Created
Sep 10, 2026 at 12:26pm UTC

We did not receive some activity & settlement files which led to this delay. Most have been received now and we will inform you as soon as the last file is processed to close this incident.