Back to overview
Degraded

Settlement delays for online payments from 21/05

May 27, 2026 at 4:47am UTC
Affected services
Portal - PROD

Resolved
May 29, 2026 at 2:29am UTC

All pending settlements have been prepared. The funds will be transferred by 09:00 today (29/05/2026). A full postmortem of the incident will be completed today to propose improvements so that we can avoid this to happen again. Incident closed.

Updated
May 28, 2026 at 3:28pm UTC

Our supplier has provided the missing settlement reports. The processing is ongoing. The settlements will be prepared this night and the payments will go out tomorrow morning. We will keep you updated once all will be processed to close this incident.

Updated
May 28, 2026 at 12:02pm UTC

Our supplier is working on providing the missing reports. We should receive them today which will enable us to proceed with all pending settlements tomorrow. The funds should then be available on the merchant bank accounts on Friday or Monday at latest.

Updated
May 28, 2026 at 5:22am UTC

Multisafepay confirmed the error to generate the reports of 22 and 23/05. The Multisafepay team js working on resolving this ASAP so we can resume the settlements. The delay is currently of 2 more days than usual.

Created
May 27, 2026 at 4:47am UTC

This impacts the settlement of online payments to the merchants. Card-present payments are not affected. The issue is expected to be resolved during the day as we are in close contact with the support of Multisafepay.